Resolved
This incident has been fully resolved and TradeMatch is operating normally. Thank you for your patience while we worked to restore service.
Resolved
This incident has been fully resolved and TradeMatch is operating normally. Thank you for your patience while we worked to restore service.
Monitoring
A fix has been implemented and we’re monitoring TradeMatch to ensure full recovery. We’ll update again if we observe any further impact.